Skip to main content
VulnerabilityPublished

CVE-2026-18353: Eclipse CSI – PIA · Server-Side Request Forgery (SSRF)

Affects Eclipse CSI – PIASource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 0.6.0 soon.

Data as of 29 Oct 2026, 07:15 UTC

CVSS 4.0 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.6.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Eclipse CSI – PIA to 0.6.0.

Affected software

ProductAffectedFixed in
Eclipse FoundationEclipse CSI - PIAAffected
  • >=0.4.0 <0.6.0
Fixed in
  • 0.6.0
GitHubEclipse CSI - PIApkg:github/Eclipse CSI - PIAOther threatsAffected
  • >=0.4.0 <0.6.0
Fixed in
  • 0.6.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid exposing the vulnerable endpoint to untrusted users or networks. Monitor for unusual outbound network activity from the affected service. Do not rely solely on issuer allowlist checks that use urlparse for validation of JWT claims containing URLs with backslashes.

Description

CVE-2026-18353 is a high-severity server-side request forgery (SSRF) vulnerability in Eclipse Foundation's Eclipse CSI - PIA version 0.4.0. The vulnerability arises from improper validation of the unverified 'iss' claim in a JWT token at the /v1/upload/sbom endpoint. Due to inconsistent parsing of URLs containing backslashes by Python's urlparse and the requests library, an attacker can bypass issuer allowlist checks and cause the server to make arbitrary network requests to attacker-controlled hosts.

References

Community reviews

Loading reviews…