Skip to main content
VulnerabilityPublished

CVE-2026-18816: Baserow · Improper Authentication

Affects BaserowSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.3 Low · fixed in 2.3.3 : update Baserow when convenient.

Data as of 3 Nov 2026, 22:58 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.3.3
CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
BaserowAffected
  • =2.3.0
  • =2.3.1
  • =2.3.2
Fixed in–
PyPIbaserowpkg:pypi/baserowOther threatsAffected
  • =2.3.0
  • =2.3.1
  • =2.3.2
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:baserow:baserow:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Baserow to version 2.3.3 or later, as this version contains the fix for the improper authentication vulnerability. No other specific mitigations are indicated.

Description

CVE-2026-18816 is an improper authentication vulnerability in Baserow affecting versions 2.3.0, 2.3.1, and 2.3.2. It involves the verify function in the two-factor authentication (2FA) verify endpoint. The vulnerability can be exploited remotely but requires high complexity and is difficult to exploit. The issue is resolved by upgrading to version 2.3.3.

References

Community reviews

Loading reviews…