CVE-2026-18817: Baserow · Improper Authorization
Affects BaserowSource CVE Database V5
Not known to be exploited · CVSS 2.1 Low · fixed in 2.3.3 : update Baserow when convenient.
Data as of 3 Nov 2026, 22:58 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.3.3
CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:XExploitation evidence
Disclosed: evidence found.
CVE published 4 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Baserow | Affected
| Fixed in– |
PyPIbaserowpkg:pypi/baserowOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:baserow:baserow:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Baserow to version 2.3.3 or later to resolve this issue. Since the maintainer considers this more of a bug than a vulnerability and no endpoints are accessible with the affected tokens, no additional mitigation steps are explicitly required.
Description
CVE-2026-18817 is a low-severity security issue in Baserow versions 2.3.0 through 2.3.2 involving improper authorization in the BaserowImpersonateAuthTokenSerializer function. The flaw allows token generation for inactive non-staff users, but the project maintainer notes that no endpoints actually work with these tokens, suggesting it is more a bug than a vulnerability. Remote exploitation is possible but considered difficult and of high complexity. Upgrading to version 2.3.3 resolves the issue.