Skip to main content
VulnerabilityPublished Updated

CVE-2026-19108: MZ Automation libiec61850 · Use After Free

Affects MZ Automation libiec61850Source CVE Database V5

0
Compare

Public exploit available · CVSS 4.8 Medium.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
MZ Automationlibiec61850Affected
  • =1.6.0
  • =1.6.1
Fixed in–
GitHubmz-automation/libiec61850pkg:github/mz-automation/libiec61850Other threatsAffected
  • =1.6.0
  • =1.6.1
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:mz_automation:libiec61850:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the affected libiec61850 component to version 1.6.2 or later, which contains the fix for this use-after-free vulnerability. No other mitigation is indicated or required.

Description

CVE-2026-19108 is a use-after-free vulnerability in MZ Automation libiec61850 versions 1.6.0 and 1.6.1. It affects the function deleteDataSetValuesShadowBuffer in the URCB Revalidation component. The vulnerability requires local access to exploit and has a medium severity score of 4.8. An exploit has been publicly disclosed. Upgrading to version 1.6.2 addresses the issue.

References

Community reviews

Loading reviews…