Skip to main content
VulnerabilityPublished

CVE-2026-19127: GitroomHQ postiz-app · CWE-345

Affects GitroomHQ postiz-appSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.21.10 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.21.10
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade GitroomHQ postiz-app to 2.21.10.

Affected software

ProductAffectedFixed in
GitroomHQpostiz-appAffected
  • <2.21.10
Fixed in
  • 2.21.10

Description

CVE-2026-19127 is a medium severity vulnerability in GitroomHQ's postiz-app affecting the billing and license activation subsystem. It allows remote attackers to bypass payment authorization by exploiting weak cryptographic validation or missing server-side state checks on promotional or lifetime-deal redemption codes. This enables unauthenticated attackers to forge or replay redemption tokens to activate the highest-tier paid subscriptions without payment.

References

Community reviews

Loading reviews…