CVE-2026-94456: GitroomHQ postiz-app · CWE-338
Affects GitroomHQ postiz-appSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 2.4.0 as a priority.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade GitroomHQ postiz-app to 2.4.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GitroomHQpostiz-app | Affected
| Fixed in
|
GitHubpostiz-apppkg:github/postiz-appOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, avoid using affected versions of postiz-app. Consider restricting access to the OAuth dynamic client registration endpoint or implementing additional monitoring to detect suspicious activity related to credential generation.
Description
Postiz-app versions before 2.4.0 generate security-sensitive credentials using a non-cryptographically secure pseudorandom number generator (Math.random()), exposing OAuth tokens and keys to compromise. An unauthenticated OAuth dynamic client registration endpoint leaks client credentials, enabling attackers to reconstruct the PRNG internal state and predict past and future credentials. This vulnerability has a critical severity with a CVSS score of 9.1.