Skip to main content
VulnerabilityPublished Updated

CVE-2026-20162: Splunk Enterprise · Cross-site Scripting

Affects Splunk EnterpriseSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium · fixed in 10.0.3 : update Splunk Enterprise when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.0.3, 9.4.9, 9.3.9 +4
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Splunk to 10.0.3, 9.4.9 or 9.3.9 (Enterprise); 10.2.2510.4, 10.1.2507.15, 10.0.2503.11 or 9.3.2411.123 (Cloud Platform).

Affected software

ProductAffectedFixed in
SplunkSplunk EnterpriseAffected
  • >=10.0 <10.0.3
Fixed in
  • 10.0.3
SplunkSplunk EnterpriseAffected
  • >=9.4 <9.4.9
Fixed in
  • 9.4.9
SplunkSplunk EnterpriseAffected
  • >=9.3 <9.3.9
Fixed in
  • 9.3.9
SplunkSplunk Cloud PlatformAffected
  • >=10.2.2510 <10.2.2510.4
Fixed in
  • 10.2.2510.4
SplunkSplunk Cloud PlatformAffected
  • >=10.1.2507 <10.1.2507.15
Fixed in
  • 10.1.2507.15
SplunkSplunk Cloud PlatformAffected
  • >=10.0.2503 <10.0.2503.11
Fixed in
  • 10.0.2503.11

AI-suggested

  1. Upgrade affected Splunk Enterprise and Cloud Platform instances to the latest patched versions (at or above 10.2.0, 10.0.3, 9.4.9, and 9.3.9 for Enterprise).
  2. Restrict the ability to create or modify Views to trusted, higher-privileged roles only, minimizing exposure to low-privileged users.
  3. Implement strict input validation and output encoding in custom Views or dashboards to prevent injection of malicious scripts.
  4. Conduct regular audits of user roles and permissions to ensure least privilege principles are enforced.
  5. Enhance phishing awareness training for users to reduce the likelihood of victims triggering malicious payloads.
  6. Monitor Splunk logs for unusual activity related to Views creation or modification endpoints.
  7. Employ Content Security Policy (CSP) headers to restrict execution of unauthorized scripts in browsers accessing Splunk interfaces.
  8. Use multi-factor authentication (MFA) to reduce risk of account compromise if session tokens are exposed.
  9. Isolate Splunk management interfaces from general user networks where feasible to limit exposure.
  10. Stay informed of vendor advisories and apply security patches promptly.

Description

In Splunk Enterprise versions below 10.2.0, 10.0.3, 9.4.9, and 9.3.9, and Splunk Cloud Platform versions below 10.2.2510.4, 10.1.2507.15, 10.0.2503.11, and 9.3.2411.123, a low-privileged user who does not hold the "admin" or "power" Splunk roles could craft a malicious payload when creating a View (Settings - User Interface - Views) at the `/manager/launcher/data/ui/views/_new` endpoint leading to a Stored Cross-Site Scripting (XSS) through a path traversal vulnerability. This could result in execution of unauthorized JavaScript code in the browser of a user. The vulnerability requires the attacker to phish the victim by tricking them into initiating a request within their browser. The authenticated user should not be able to exploit the vulnerability at will.

References

Community reviews

Loading reviews…