CVE-2026-20257: Splunk Enterprise · The product does not validate or incorrectly validates input that can affect the control flow or data flow of a program.
Affects Splunk EnterpriseSource CVE Database V5
Not known to be exploited · CVSS 5.7 Medium · fixed in 10.2.4 : update Splunk Enterprise when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.2.4, 10.0.7, 9.4.12 +5
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Splunk to 10.2.4, 10.0.7, 9.4.12 or 9.3.13 (Enterprise); 10.3.2512.13, 10.2.2510.15, 10.1.2507.23 or 9.3.2411.132 (Cloud Platform).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SplunkSplunk Enterprise | Affected
| Fixed in
|
| SplunkSplunk Enterprise | Affected
| Fixed in
|
| SplunkSplunk Enterprise | Affected
| Fixed in
|
| SplunkSplunk Enterprise | Affected
| Fixed in
|
| SplunkSplunk Cloud Platform | Affected
| Fixed in
|
| SplunkSplunk Cloud Platform | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict dashboard creation permissions to trusted users and educate users to be cautious of phishing attempts that could trigger malicious dashboards.
Description
In Splunk Enterprise versions below 10.2.4, 10.0.7, 9.4.12, and 9.3.13, and Splunk Cloud Platform versions below 10.3.2512.13, 10.2.2510.15, 10.1.2507.23, and 9.3.2411.132, a low-privileged user that does not hold the "admin" or "power" Splunk roles could craft a classic dashboard that exfiltrates sensitive data from the browser of a higher-privileged user who views it. The exfiltration is possible because classic dashboard panels do not fully validate style attribute values, which can allow for requests to reach external domains outside the configured Trusted Domains List. The vulnerability requires the attacker to phish the victim by tricking them into initiating a request within their browser. The low-privileged user should not be able to exploit the vulnerability at will.