Skip to main content
VulnerabilityPublished

CVE-2026-21424: Dell PowerScale OneFS · Execution with Unnecessary Privileges

Affects Dell PowerScale OneFSSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.7 Medium : upgrade to 9.13.0.0 or later or 9.10.1.6 or later when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.7Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.13.0.0 or later, 9.10.1.6 or later, 9.10.1.6
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade PowerScale OneFS to 9.13.0.0 or later or 9.10.1.6 or later; dell/powerscale-onefs to 9.10.1.6.

Affected software

ProductAffectedFixed in
DellPowerScale OneFSAffected
  • ≥ prior to 9.10.1.6, < 9.10.1.6 or later
  • ≥ 9.11.0.0 through 9.12.0.1, < 9.13.0.0 or later
Fixed in
  • 9.13.0.0 or later
  • 9.10.1.6 or later
Delldell/powerscale-onefspkg:rpm/dell/powerscale-onefsOther threatsAffected
  • <9.10.1.6
  • >=9.11.0.0 <=9.12.0.1
Fixed in
  • 9.10.1.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should implement the following specific mitigations: 1) Immediately restrict local access to Dell PowerScale OneFS systems to only trusted, essential personnel to reduce the risk of privilege escalation by insiders or compromised accounts. 2) Monitor and audit all administrative and high-privilege user activities on OneFS systems to detect suspicious behavior indicative of exploitation attempts. 3) Apply security best practices such as multi-factor authentication for administrative access to reduce the risk of credential compromise. 4) Stay in close contact with Dell for official patches or updates addressing CVE-2026-21424 and apply them promptly once available. 5) Consider deploying host-based intrusion detection systems (HIDS) on OneFS nodes to detect anomalous privilege escalation activities. 6) Review and minimize the number of users with high privileges on OneFS systems to reduce the attack surface. 7) Conduct regular security assessments and penetration testing focused on privilege escalation vectors within the storage environment.

Description

Dell PowerScale OneFS, versions prior to 9.10.1.6 and versions 9.11.0.0 through 9.12.0.1, contains an execution with unnecessary privileges vulnerability. A high privileged attacker with local access could potentially exploit this vulnerability, leading to Elevation of privileges.

References

Community reviews

Loading reviews…