Skip to main content
VulnerabilityPublished

CVE-2026-21426: Dell PowerScale OneFS · Execution with Unnecessary Privileges

Affects Dell PowerScale OneFSSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.7 Medium : upgrade to 9.13.0.0 or later or 9.10.1.6 or later when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.7Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.13.0.0 or later, 9.10.1.6 or later, 9.10.1.6
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade PowerScale OneFS to 9.13.0.0 or later or 9.10.1.6 or later; dell/powerscale-onefs to 9.10.1.6.

Affected software

ProductAffectedFixed in
DellPowerScale OneFSAffected
  • ≥ prior to 9.10.1.6, < 9.10.1.6 or later
  • ≥ 9.11.0.0 through 9.12.0.1, < 9.13.0.0 or later
Fixed in
  • 9.13.0.0 or later
  • 9.10.1.6 or later
Delldell/powerscale-onefspkg:rpm/dell/powerscale-onefsOther threatsAffected
  • <9.10.1.6
  • >=9.11.0.0 <=9.12.0.1
Fixed in
  • 9.10.1.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should implement the following specific mitigation measures: 1) Immediately restrict and audit local high privileged access to Dell PowerScale OneFS systems, ensuring only authorized personnel have administrative rights. 2) Monitor system logs and user activities for unusual or unauthorized actions indicative of privilege abuse or attempts to exploit this vulnerability. 3) Apply principle of least privilege to all users and services interacting with OneFS to minimize the risk surface. 4) Segregate administrative duties and use multi-factor authentication for all high privileged accounts to reduce risk of credential compromise. 6) Consider deploying host-based intrusion detection systems (HIDS) or endpoint protection solutions capable of detecting privilege escalation attempts on storage nodes. 7) Conduct regular security assessments and penetration testing focused on local privilege escalation vectors within storage infrastructure. These measures go beyond generic advice by focusing on controlling local high privileged access and proactive monitoring until official patches are released.

Description

Dell PowerScale OneFS, versions prior to 9.10.1.6 and versions 9.11.0.0 through 9.12.0.1, contains an execution with unnecessary privileges vulnerability. A high privileged attacker with local access could potentially exploit this vulnerability, leading to denial of service, elevation of privileges, and information disclosure.

References

Community reviews

Loading reviews…