Skip to main content
VulnerabilityPublished

CVE-2026-21588: Atlassian Confluence Data Center · DoS

Affects Atlassian Confluence Data CenterSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 10.2.17 or 9.2.24 soon.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.2.17, 9.2.24
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade com.atlassian.confluence/confluence-data-center to 10.2.17 or 9.2.24.

Affected software

ProductAffectedFixed in
AtlassianConfluence Data CenterAffected
  • 8.9.7 to 8.9.8 – 10.2.0 to 10.2.15
9 affected builds
Fixed in–
Mavencom.atlassian.confluence/confluence-data-centerpkg:maven/com.atlassian.confluence/confluence-data-centerOther threatsAffected
  • 8.9.0 – 10.1.0
  • >=9.2.0 <9.2.24
  • >=10.2.0 <10.2.17
8 affected builds
Fixed in
  • 9.2.24
  • 10.2.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Atlassian has provided official fixes for this vulnerability. Customers should upgrade Confluence Data Center to versions 9.2.24 or later if on the 9.2 branch, or 10.2.17 or later if on the 10.2 branch. If possible, upgrading to the latest available version is recommended. Patch status is confirmed as fixed in these versions. No other mitigation actions are specified.

Description

This High severity DoS (Denial of Service) vulnerability was introduced in versions 8.9.0, 9.0.1, 9.1.0, 9.2.0, 9.3.1, 9.4.0, 9.5.1, 10.0.2, 10.1.0, and 10.2.0 of Confluence Data Center. This DoS (Denial of Service) vulnerability, with a CVSS Score of 7.1, allows an authenticated attacker to cause a resource to be unavailable for its intended users by temporarily or indefinitely disrupting services of a host connected to a network. Atlassian recommends that Confluence Data Center customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Confluence Data Center 9.2: Upgrade to a release greater than or equal to 9.2.24 Confluence Data Center 10.2: Upgrade to a release greater than or equal to 10.2.17 See the release notes ([https://confluence.atlassian.com/doc/confluence-release-notes-327.html]). You can download the latest version of Confluence Data Center from the download center ([https://www.atlassian.com/software/confluence/download-archives]). This vulnerability was reported via our Penetration Testing program.

References

Community reviews

Loading reviews…