CVE-2026-22337: Directorist Social Login (WordPress plugin) · Incorrect Privilege Assignment
Affects Directorist Social Login (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 2.1.4 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.1.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Directorist Social Login (WordPress plugin) to 2.1.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DirectoristDirectorist Social Login | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, consider restricting access to the affected plugin or disabling it if feasible to reduce exposure.
Description
CVE-2026-22337 is a critical vulnerability in the Directorist Social Login plugin caused by incorrect privilege assignment, allowing privilege escalation. It affects versions before 2.1.4. The vulnerability has a high CVSS score of 9.8, indicating it can be exploited remotely without user interaction to fully compromise confidentiality, integrity, and availability. There are no known exploits in the wild at this time.