CVE-2026-22593: everest-core · Off-by-one Error
Affects everest-coreSource CVE Database V5
Not known to be exploited · CVSS 8.4 High : upgrade to 2026.02.0 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.02.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 26 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade everest-core and everest/everest-core to 2026.02.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| EVeresteverest-core | Affected
| Fixed in
|
GitHubeverest/everest-corepkg:github/everest/everest-coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official patch is available in EVerest everest-core version 2026.02.0. Users should upgrade to this version or later to remediate the vulnerability. Since this is not a cloud service, remediation depends on applying the vendor's patch. Patch status is confirmed by the vendor advisory indicating the fix in version 2026.02.0.
Description
CVE-2026-22593 is a high-severity vulnerability in the EVerest everest-core EV charging software stack. It is caused by an off-by-one error in the IsoMux certificate filename handling prior to version 2026.02.0. When a filename length equals the maximum allowed length (100), a stack-based buffer overflow occurs, potentially allowing corruption of stack state and code execution. This vulnerability is patched in version 2026.02.0.