CVE-2026-2266: GitHub Enterprise Server · Cross-site Scripting
Affects GitHub Enterprise ServerSource CVE Database V5
Not known to be exploited · CVSS 7.4 High : upgrade to 3.19.3 or 3.18.6 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.19.3, 3.18.6
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade GitHub Enterprise Server to 3.19.3 or 3.18.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GitHubEnterprise Server | Affected
| Fixed in
|
| GitHubEnterprise Server | Affected
| Fixed in
|
AI-suggested
Organizations should immediately upgrade GitHub Enterprise Server to versions 3.18.6, 3.19.3, or later, where the vulnerability has been patched. Until upgrades are applied, administrators should restrict access to the affected versions by limiting user privileges and monitoring for suspicious activity related to task list content in issues and pull requests. Implementing strict content security policies (CSP) can help mitigate the impact of XSS by restricting script execution sources. Additionally, organizations should educate users about the risks of interacting with untrusted task list items and encourage vigilance for unusual behavior. Regularly auditing and reviewing pull requests and issues for suspicious content can also help detect attempted exploitation. Finally, integrating automated scanning tools that detect XSS patterns in user-generated content within the GitHub environment can provide early warning.
Description
An improper neutralization of input vulnerability was identified in GitHub Enterprise Server that allowed DOM-based cross-site scripting via task list content. The task list content extraction logic did not properly re-encode browser-decoded text nodes before rendering, allowing user-supplied HTML to be injected into the page. An authenticated attacker could craft malicious task list items in issues or pull requests to execute arbitrary scripts in the context of another user's browser session. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.20 and was fixed in versions 3.18.6 and 3.19.3. This vulnerability was reported via the GitHub Bug Bounty program.