Skip to main content
VulnerabilityPublished

CVE-2026-22731: Spring Boot · Authentication bypass using an alternate path or channel

Affects Spring BootSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 8.2 High · fixed in 4.0.3 : patch Spring Boot soon.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.3, 3.5.11, 3.4.15
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade Spring Boot and org.springframework.boot/spring-boot to 4.0.3, 3.5.11 or 3.4.15.

Affected software

ProductAffectedFixed in
SpringSpring BootAffected
  • >=4.0 <4.0.3
Fixed in
  • 4.0.3
SpringSpring BootAffected
  • >=3.5 <3.5.11
Fixed in
  • 3.5.11
SpringSpring BootAffected
  • >=3.4 <3.4.15
Fixed in
  • 3.4.15
Mavenorg.springframework.boot/spring-bootpkg:maven/org.springframework.boot/spring-bootOther threatsAffected
  • <4.0.3
  • >=3.5 <3.5.11
  • >=3.4 <3.4.15
Fixed in
  • 4.0.3
  • 3.5.11
  • 3.4.15

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-22731, organizations should immediately upgrade Spring Boot to versions 4.0.3 or later, 3.5.11 or later, or 3.4.15 or later where the vulnerability is patched. If upgrading is not immediately feasible, administrators must audit and restrict access to Actuator endpoints, ensuring that authentication is enforced consistently across all paths, including those configured as Health Group additional paths. Implement network-level access controls such as IP whitelisting or VPN-only access to sensitive management endpoints. Review and avoid declaring application endpoints under paths already used by Health Groups to prevent bypass scenarios. Employ security best practices such as using strong authentication mechanisms (e.g., OAuth2, Basic Auth with strong credentials) and enabling HTTPS to protect data in transit. Regularly monitor application logs for suspicious access patterns to Actuator endpoints. Additionally, conduct thorough security testing and code reviews focusing on endpoint configuration and access control logic. Finally, maintain awareness of related vulnerabilities like CVE-2026-22733 to ensure comprehensive protection.

Description

Spring Boot applications with Actuator can be vulnerable to an "Authentication Bypass" vulnerability when an application endpoint that requires authentication is declared under a specific path, already configured for a Health Group additional path. This issue affects Spring Boot: from 4.0 before 4.0.3, from 3.5 before 3.5.11, from 3.4 before 3.4.15. This CVE is similar but not equivalent to CVE-2026-22733, as the conditions for exploit and vulnerable versions are different.

References

Community reviews

Loading reviews…