Skip to main content
VulnerabilityPublished Updated

CVE-2026-22895: QNAP Systems QuFTP Service · Cross-site Scripting

Affects QNAP Systems QuFTP ServiceSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.2 Medium · fixed in 1.6.2 : update QNAP Systems QuFTP Service when convenient.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 4.0 base score
6.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.2, 1.5.2, 1.4.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade QNAP Systems QuFTP Service to 1.6.2, 1.5.2 or 1.4.3.

Affected software

ProductAffectedFixed in
QNAP Systems Inc.QuFTP ServiceAffected
  • >=1.6.0 <1.6.2
Fixed in
  • 1.6.2
QNAP Systems Inc.QuFTP ServiceAffected
  • >=1.5.0 <1.5.2
Fixed in
  • 1.5.2
QNAP Systems Inc.QuFTP ServiceAffected
  • >=1.4.0 <1.4.3
Fixed in
  • 1.4.3

AI-suggested

The vulnerability has been fixed in QuFTP Service versions 1.4.3, 1.5.2, and 1.6.2 and later. Users should upgrade affected installations from versions 1.4.0, 1.5.0, and 1.6.0 to these patched versions or later to remediate the issue.

Description

A cross-site scripting (XSS) vulnerability has been reported to affect QuFTP Service. If a remote attacker gains an administrator account, they can then exploit the vulnerability to bypass security mechanisms or read application data. We have already fixed the vulnerability in the following versions: QuFTP Service 1.4.3 and later QuFTP Service 1.5.2 and later QuFTP Service 1.6.2 and later

References

Community reviews

Loading reviews…