Skip to main content
VulnerabilityPublished

CVE-2026-23737: lxsmnsyc seroval · Deserialization of Untrusted Data

Affects lxsmnsyc serovalSource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High : upgrade to 1.4.1 soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.4.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade seroval and lxsmnsyc/seroval to 1.4.1.

Affected software

ProductAffectedFixed in
lxsmnsycserovalAffected
  • <1.4.1
Fixed in
  • 1.4.1
npmlxsmnsyc/serovalpkg:npm/lxsmnsyc/serovalOther threatsAffected
  • <1.4.1
Fixed in
  • 1.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade all instances of the seroval library to version 1.4.1 or later, where the vulnerability is fixed. Beyond patching, implement strict input validation and sanitization on all client-to-server JSON data transmissions to prevent injection of malicious serialized payloads. Employ runtime application self-protection (RASP) or Web Application Firewalls (WAFs) configured to detect anomalous request patterns indicative of exploitation attempts, such as multiple similar requests targeting deserialization functions. Conduct thorough code reviews and security testing focusing on serialization and deserialization logic, especially where complex data structures are involved. Limit the privileges of processes handling serialized data to reduce the impact of potential code execution. Monitor logs for unusual activity related to the fromJSON and fromCrossJSON functions, including repeated requests or malformed data. Educate developers on secure serialization practices and the risks of unsafe deserialization. Finally, consider implementing Content Security Policy (CSP) headers to mitigate the impact of injected scripts in web contexts.

Description

CVE-2026-23737 is a high-severity deserialization vulnerability in the lxsmnsyc seroval library versions below 1.4.1. The flaw exists in the fromJSON and fromCrossJSON functions, which improperly handle untrusted input during JSON deserialization, enabling arbitrary JavaScript code execution. Exploitation requires an attacker to perform multiple requests with partial knowledge of serialized data usage, without user interaction but with low privileges. This vulnerability can compromise confidentiality, integrity, and availability of affected systems. Although no known exploits are reported in the wild, the risk is significant due to the potential for remote code execution. The issue is fixed in version 1.4.1.

References

Community reviews

Loading reviews…