CVE-2026-23858: Dell Wyse Management Suite · Cross-site Scripting
Affects Dell Wyse Management SuiteSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 5.5 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Dell Wyse Management Suite to 5.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DellWyse Management Suite | Affected
| Fixed in
|
AI-suggested
1. 2. If you cannot patch yet, restrict network access to the management interface using firewalls, VPNs, or IP whitelisting to limit exposure to trusted users only. 3. Implement web application firewalls (WAFs) with rules to detect and block common XSS attack patterns targeting the management suite. 4. Enforce strict input validation and output encoding on all user-supplied data within the management console to prevent script injection. 5. Educate administrators and users to avoid clicking on suspicious links or interacting with untrusted content that could trigger XSS payloads. 6. Monitor logs and network traffic for anomalous activities indicative of exploitation attempts. 7. Consider deploying Content Security Policy (CSP) headers to reduce the impact of any injected scripts by restricting script sources. 8. Regularly review and audit user privileges to ensure minimal necessary access is granted, reducing the potential impact of compromised accounts.
Description
Dell Wyse Management Suite, versions prior to WMS 5.5, contain an Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability. A low privileged attacker with remote access could potentially exploit this vulnerability, leading to Script Injection.