CVE-2026-23902: Apache DolphinScheduler · Incorrect Authorization
Affects Apache DolphinSchedulerSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 3.4.1 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.4.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Apache DolphinScheduler and org.apache.dolphinscheduler/dolphinscheduler and Apache Software Foundation/org.apache.dolphinscheduler:dolphinscheduler-api to 3.4.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache DolphinScheduler | Affected
| Fixed in
|
Mavenorg.apache.dolphinscheduler/dolphinschedulerpkg:maven/org.apache.dolphinscheduler/dolphinschedulerOther threats | Affected
| Fixed in
|
MavenApache Software Foundation/org.apache.dolphinscheduler:dolphinscheduler-apipkg:maven/Apache Software Foundation/org.apache.dolphinscheduler:dolphinscheduler-apiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache DolphinScheduler to version 3.4.1 or later, where this incorrect authorization vulnerability is fixed. No other mitigation or temporary workaround is specified. Patch status is confirmed by the vendor advisory recommending the upgrade.
Description
CVE-2026-23902 is an incorrect authorization vulnerability in Apache DolphinScheduler prior to version 3.4.1. Authenticated users with system login permissions can execute workflows using tenants not defined on the platform. This could lead to unauthorized access or actions within the system. The vulnerability has a high severity with a CVSS score of 8.1. Users are advised to upgrade to version 3.4.1, which addresses this issue.