CVE-2026-23904: Apache Kyuubi · Improper Restriction of Communication Channel to Intended Endpoints
Affects Apache KyuubiSource CVE Database V5
Not known to be exploited · CVSS 7.3 High : upgrade to 1.12.0 soon.
Data as of 27 Oct 2026, 17:11 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.12.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 29 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Apache to 1.12.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Kyuubi | Affected
| Fixed in
|
MavenApache Software Foundation/org.apache.kyuubi:kyuubi-serverpkg:maven/Apache Software Foundation/org.apache.kyuubi:kyuubi-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade to Apache Kyuubi version 1.12.0 or later, where the Engine UI proxy is disabled by default. If proxy functionality is required, it must be explicitly enabled by setting 'kyuubi.frontend.rest.engine.ui.proxy.enabled=true' and restricting allowed target hosts using 'kyuubi.frontend.rest.engine.ui.proxy.hosts' configuration. This mitigates the risk by limiting proxy targets and reducing exposure.
Description
Apache Kyuubi versions from 1.8.0 before 1.12.0 contain a vulnerability in the Engine UI proxy component that allows remote attackers with network access to cause the server to send HTTP requests to arbitrary hosts. This behavior can lead to Server-Side Request Forgery (SSRF) or open-proxy issues. The vulnerability is addressed in version 1.12.0, which disables the proxy by default and requires explicit configuration to enable it safely.