Skip to main content
VulnerabilityPublished

CVE-2026-62391: Apache Kyuubi · Path Traversal

Affects Apache KyuubiSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 8.1 High : upgrade to 1.12.0 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.12.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache to 1.12.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache KyuubiAffected
  • >=1.6.0 <1.12.0
Fixed in
  • 1.12.0
MavenApache Software Foundation/org.apache.kyuubi:kyuubi-serverpkg:maven/Apache Software Foundation/org.apache.kyuubi:kyuubi-serverOther threatsAffected
  • >=1.6.0 <1.12.0
Fixed in
  • 1.12.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Kyuubi to version 1.12.0, which contains the fix for this vulnerability. No other official remediation or temporary fixes are indicated. Patch status is not explicitly confirmed in the provided data, but the vendor recommends upgrading to 1.12.0 to resolve the issue.

Description

CVE-2026-62391 is a path traversal vulnerability in Apache Kyuubi affecting versions from 1.6.0 up to but not including 1.12.0. The issue arises because the security fix for a previous vulnerability (CVE-2025-66518) is incomplete, allowing clients with access to the Kyuubi Server via frontend protocols to bypass server-side directory allowlist restrictions using unprefixed Spark config aliases. This vulnerability has a high severity score of 8.1 and impacts confidentiality and integrity without affecting availability.

References

Community reviews

Loading reviews…