Skip to main content
VulnerabilityPublished Updated

CVE-2026-23943: Erlang OTP · Data Amplification

Affects Erlang OTPSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 5.5.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.5.1, 28.4.1, 5.2.11.6 +1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade OTP and ssh to 5.5.1; OTP and erlang/otp to 28.4.1; erlang/otp to 5.5.1, 5.2.11.6 or 5.1.4.14.

Affected software

ProductAffectedFixed in
ErlangOTPAffected
  • >=3.0.1 <5.5.1
Fixed in
  • 5.5.1
ErlangOTPAffected
  • >=17.0 <28.4.1
Fixed in
  • 28.4.1
GitHuberlang/otppkg:github/erlang/otpOther threatsAffected
  • 3.0.1 <5.5.1
  • <5.2.11.6
  • <5.1.4.14
Fixed in
  • 5.5.1
  • 5.2.11.6
  • 5.1.4.14
GitHubsshpkg:github/sshOther threatsAffected
  • >=3.0.1 <5.5.1
Fixed in
  • 5.5.1
GitHuberlang/otppkg:github/erlang/otpOther threatsAffected
  • >=17.0 <28.4.1
Fixed in
  • 28.4.1

CPE configurations (1)

  • cpe:2.3:a:erlang:erlang\/otp:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Until an official fix or update is available, consider disabling legacy zlib compression in the SSH transport layer to prevent unauthenticated decompression attacks. Monitor for vendor updates regarding patched versions OTP 28.4.1, OTP 27.3.4.9, and OTP 26.2.5.18 and corresponding SSH versions 5.5.1, 5.2.11.6, and 5.1.4.14.

Description

Improper Handling of Highly Compressed Data (Compression Bomb) vulnerability in Erlang OTP ssh (ssh_transport modules) allows Denial of Service via Resource Depletion. The SSH transport layer advertises legacy zlib compression by default and inflates attacker-controlled payloads pre-authentication without any size limit, enabling reliable memory exhaustion DoS. Two compression algorithms are affected: * zlib: Activates immediately after key exchange, enabling unauthenticated attacks * zlib@openssh.com: Activates post-authentication, enabling authenticated attacks Each SSH packet can decompress ~255 MB from 256 KB of wire data (1029:1 amplification ratio). Multiple packets can rapidly exhaust available memory, causing OOM kills in memory-constrained environments. This vulnerability is associated with program files lib/ssh/src/ssh_transport.erl and program routines ssh_transport:decompress/2, ssh_transport:handle_packet_part/4. This issue affects OTP from OTP 17.0 before OTP 28.4.1, OTP 27.3.4.9 and OTP 26.2.5.18, corresponding to ssh from 3.0.1 before 5.5.1, 5.2.11.6 and 5.1.4.14.

References

Community reviews

Loading reviews…