Skip to main content
VulnerabilityPublished

CVE-2026-23981: Apache Superset · Improper Authorization

Affects Apache SupersetSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 6.0.0 when convenient.

Data as of 29 Oct 2026, 07:15 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache Superset and org.apache.superset/superset to 6.0.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache SupersetAffected
  • <6.0.0
Fixed in
  • 6.0.0
Mavenorg.apache.superset/supersetpkg:maven/org.apache.superset/supersetOther threatsAffected
  • <6.0.0
Fixed in
  • 6.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Superset to version 6.0.0 or later, where this improper authorization vulnerability is fixed. No other mitigation or temporary workaround is specified.

Description

An Improper Authorization vulnerability exists in Apache Superset allowing an authenticated user with permissions to update charts to modify dashboards they do not own. When updating a chart's properties via the REST API, a user can provide a list of dashboard IDs (dashboards) to associate the chart with. The validation logic in the UpdateChartCommand failed to verify that the user had write permissions for the target dashboards specified in the request body. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

References

Community reviews

Loading reviews…