CVE-2025-55675: Apache Superset · Improper Authorization
Affects Apache SupersetSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium · fixed in 5.0.0 : update Apache Superset when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software Foundation Apache Superset | Affected
| Fixed in– |
AI-suggested
European organizations should immediately upgrade Apache Superset to version 5.0.0 or later, where the vulnerability is fixed. Until the upgrade can be performed, implement strict access control policies to limit authenticated user permissions, ensuring users only have access to datasources necessary for their roles. Monitor and audit user activity on the /explore endpoint to detect unusual enumeration patterns indicative of exploitation attempts. Employ network segmentation and firewall rules to restrict access to the Superset instance to trusted users and IP ranges. Additionally, enforce strong authentication mechanisms, such as multi-factor authentication (MFA), to reduce the risk of compromised credentials being used to exploit this vulnerability. Regularly review and update datasource permissions and conduct security awareness training to inform users about the risks of unauthorized data access. Finally, maintain an up-to-date inventory of Superset deployments and ensure timely application of security patches.
Description
Apache Superset contains an improper access control vulnerability in its /explore endpoint. A missing authorization check allows an authenticated user to discover metadata about datasources they do not have permission to access. By iterating through the datasource_id in the URL, an attacker can enumerate and confirm the existence and names of protected datasources, leading to sensitive information disclosure. This issue affects Apache Superset: before 5.0.0. Users are recommended to upgrade to version 5.0.0, which fixes the issue.