Skip to main content
CVE-2026-24130VulnerabilityPublished

CVE-2026-24130: Arksine moonraker · LDAP Injection

Affects Arksine moonrakerSource CVE Database V5

0

Not known to be exploited · CVSS 2.7 Low : upgrade to 0.10.0 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
2.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.10.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Arksine moonraker to 0.10.0.

Affected software

ProductAffectedFixed in
ArksinemoonrakerAffected
  • <0.10.0
Fixed in
  • 0.10.0
PyPImoonrakerpkg:pypi/moonrakerOther threatsAffected
  • <0.10.0
Fixed in
  • 0.10.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade Moonraker instances to version 0.10.0 or later, where the LDAP injection vulnerability has been fixed. If upgrading is not immediately feasible, disable the ldap component to eliminate exposure. Restrict network access to the Moonraker login endpoint using firewalls or VPNs to limit potential attackers. Implement robust input validation and sanitization on all LDAP-related inputs beyond the vendor patch. Monitor logs for unusual LDAP query patterns or repeated 401 responses indicative of brute force enumeration attempts. Employ network segmentation to isolate 3D printing infrastructure from critical enterprise systems. Conduct regular security assessments of Moonraker deployments and related authentication mechanisms. Finally, educate administrators about the risks of LDAP injection and the importance of timely patching.

Description

CVE-2026-24130 is an LDAP injection vulnerability in Arksine's Moonraker Python web server versions 0.9.3 and below when the ldap component is enabled. The flaw allows attackers to manipulate LDAP search filters via the login endpoint, exploiting error messages to enumerate LDAP entries such as user IDs and attributes. This vulnerability does not require authentication or user interaction and has a low CVSS score of 2.7, indicating limited impact. The issue was fixed in version 0.10.0. While no known exploits are reported in the wild, affected instances could leak sensitive directory information, potentially aiding further attacks.

References

Community reviews

Loading reviews…