CVE-2026-24157: NVIDIA NeMo Framework · Deserialization of Untrusted Data
Affects NVIDIA NeMo FrameworkSource CVE Database V5
Not known to be exploited · CVSS 7.8 High : upgrade to 2.6.2 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.6.2
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 24 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade nvidia-nemo to 2.6.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| NVIDIANeMo Framework | Affected
| Fixed in– |
PyPInvidia-nemopkg:pypi/nvidia-nemoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should update NVIDIA NeMo Framework to version 2.6.2 or later to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.
Description
CVE-2026-24157 is a high-severity vulnerability in the NVIDIA NeMo Framework affecting versions prior to 2.6.2. It involves deserialization of untrusted data during checkpoint loading, which could allow an attacker with local privileges to execute arbitrary code, escalate privileges, disclose information, and tamper with data. A patch is available to address this issue.