Skip to main content
VulnerabilityPublished Updated

CVE-2026-24308: Apache ZooKeeper · Sensitive Data in Logs

Affects Apache ZooKeeperSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.9.5 or 3.8.6 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.1% chance of exploitation in 30 days – higher than 68% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.9.5, 3.8.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade org.apache.zookeeper/zookeeper to 3.9.5 or 3.8.6.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ZooKeeperAffected
  • >=3.9.0 <=3.9.4
  • >=3.8.0 <=3.8.5
Fixed in–
Mavenorg.apache.zookeeper/zookeeperpkg:maven/org.apache.zookeeper/zookeeperOther threatsAffected
  • <3.8.6
  • <3.9.5
Fixed in
  • 3.8.6
  • 3.9.5
MavenApache Software Foundation/org.apache.zookeeper:zookeeperpkg:maven/Apache Software Foundation/org.apache.zookeeper:zookeeperOther threatsAffected
  • >=3.9.0 <=3.9.4
  • >=3.8.0 <=3.8.5
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache ZooKeeper to versions 3.8.6 or 3.9.5 or later, where this issue is fixed. Red Hat advisories provide security updates addressing this vulnerability. Patch status is confirmed with official fixes available. No additional mitigations are specified beyond applying the update.

Description

Improper handling of configuration values in ZKConfig in Apache ZooKeeper 3.8.5 and 3.9.4 on all platforms allows an attacker to expose sensitive information stored in client configuration in the client's logfile. Configuration values are exposed at INFO level logging rendering potential production systems affected by the issue. Users are recommended to upgrade to version 3.8.6 or 3.9.5 which fixes this issue.

References

Community reviews

Loading reviews…