CVE-2026-24505: Dell PowerProtect Data Domain · Improper Input Validation
Affects Dell PowerProtect Data DomainSource CVE Database V5
Not known to be exploited · CVSS 7.2 High : upgrade to 8.6.1.10 or 2.7.9 with DD OS 8.3.1.30 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.6.1.10, 2.7.9 with DD OS 8.3.1.30
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Dell PowerProtect Data Domain to 8.6.1.10 or 2.7.9 with DD OS 8.3.1.30.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DellPowerProtect Data Domain | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict remote access to high privileged users and monitor for suspicious activity related to command execution. Follow Dell's official communications for updates on patches or mitigations.
Description
Dell PowerProtect Data Domain, versions 8.5 through 8.6 contain an improper input validation vulnerability. A high privileged attacker with remote access could potentially exploit this vulnerability, leading to arbitrary command execution with root privileges.