CVE-2026-2472: Google Cloud Vertex AI SDK for Python · XSS or 'Cross-site Scripting'
Affects Google Cloud Vertex AI SDK for PythonSource CVE Database V5
Not known to be exploited · CVSS 8.6 High : upgrade to 1.131.0 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.131.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/U:AmberExploitation evidence
Disclosed: evidence found.
CVE published 20 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Google Cloud Vertex AI SDK for Python to 1.131.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Google CloudVertex AI SDK for Python | Affected
| Fixed in
|
AI-suggested
Google manages remediation for this cloud-hosted service and has already applied mitigations to the affected products and services. Users should ensure they are using versions of the Vertex AI SDK for Python at or above 1.131.0 where the vulnerability is fixed. Refer to the official Google advisory at https://docs.cloud.google.com/support/bulletins#gcp-2026-011 for detailed guidance. No additional customer action is required if using the managed cloud service, but updating SDK versions is recommended where applicable.
Description
Stored Cross-Site Scripting (XSS) in the _genai/_evals_visualization component of Google Cloud Vertex AI SDK (google-cloud-aiplatform) versions from 1.98.0 up to (but not including) 1.131.0 allows an unauthenticated remote attacker to execute arbitrary JavaScript in a victim's Jupyter or Colab environment via injecting script escape sequences into model evaluation results or dataset JSON data.
References
- docs.cloud.google.com/support/bulletins (opens in a new tab)
- github.com/JoshuaProvoste/CVE-2026-2472-Vertex-AI-SDK-Google-Cloud (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-2472 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2441472 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-2472.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:10184 (opens in a new tab)