CVE-2026-24752: kiteworks Secure Data Forms · Cross-site Scripting
Affects kiteworks Secure Data FormsSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 9.3.0 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.3.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade kiteworks Secure Data Forms to 9.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| kiteworksSecure Data Forms | Affected
| Fixed in
|
AI-suggested
Upgrade kiteworks Secure Data Forms to version 9.3.0 or later to apply the official patch that resolves this vulnerability. No other vendor advisories or temporary mitigations are provided. Patch status is not explicitly confirmed beyond the upgrade recommendation; verify with the vendor advisory for current remediation guidance.
Description
A reflected cross-site scripting (XSS) vulnerability exists in kiteworks Secure Data Forms prior to version 9.3.0. This vulnerability allows an external attacker to trick a user into executing arbitrary JavaScript code. The issue is fixed in version 9.3.0 and later.