Skip to main content
VulnerabilityPublished Updated

CVE-2026-24906: octobercms october · Cross-site Scripting

Affects octobercms octoberSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.1 Medium : upgrade to 4.1.10 or 3.7.14 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.10, 3.7.14
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade october to 4.1.10 or 3.7.14; octobercms/october to 3.7.14.

Affected software

ProductAffectedFixed in
octobercmsoctoberAffected
  • >=4.0.0 <4.1.10
Fixed in
  • 4.1.10
octobercmsoctoberAffected
  • <3.7.14
Fixed in
  • 3.7.14
GitHuboctobercms/octoberpkg:github/octobercms/octoberOther threatsAffected
  • <3.7.14
Fixed in
  • 3.7.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in OctoberCMS versions 3.7.14 and 4.1.10. Users should upgrade to these or later versions to remediate the issue. Until patched, restrict editor settings permissions strictly to fully trusted administrators to reduce the risk of exploitation.

Description

OctoberCMS versions prior to 3.7.14 and 4.1.10 contain a stored Cross-Site Scripting (XSS) vulnerability in the Backend Editor Settings. The vulnerability arises because the Markup Classes fields do not properly sanitize input, allowing malicious JavaScript to execute when a user opens a RichEditor. Exploitation requires authenticated backend access with editor settings permissions and could lead to privilege escalation if a superuser opens the editor. The issue has been fixed in versions 3.7.14 and 4.

References

Community reviews

Loading reviews…