Skip to main content
VulnerabilityPublished Updated

CVE-2026-25001: Post Snippets (WordPress plugin) · Code Injection

Affects Post Snippets (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.5 High : upgrade to 4.0.13 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.13
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Post Snippets (WordPress plugin) to 4.0.13.

Affected software

ProductAffectedFixed in
Saad IqbalPost SnippetsAffected
  • <4.0.13
Fixed in
  • 4.0.13

AI-suggested

If you cannot patch yet, consider disabling or removing the Post Snippets plugin if feasible, or applying any available temporary mitigations recommended by the vendor.

Description

Improper Control of Generation of Code ('Code Injection') vulnerability in Saad Iqbal Post Snippets post-snippets allows Remote Code Inclusion.This issue affects Post Snippets: from n/a through <= 4.0.12.

References

Community reviews

Loading reviews…