CVE-2026-25076: Anchore Enterprise · SQL Injection
Affects Anchore EnterpriseSource CVE Database V5
Not known to be exploited · CVSS 8.5 High : upgrade to 5.25.1 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.25.1
CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 12 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Anchore Enterprise to 5.25.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AnchoreAnchore Enterprise | Affected
| Fixed in
|
AI-suggested
- Upgrade Anchore Enterprise to version 5.25.1 or later immediately to apply the official patch that fixes the SQL injection vulnerability.
- Restrict access to the GraphQL Reports API strictly to trusted and authenticated users, employing strong authentication mechanisms such as multi-factor authentication (MFA).
- Implement network segmentation and firewall rules to limit API access to only necessary internal systems or trusted IP ranges.
- Monitor API usage logs for unusual or suspicious query patterns that may indicate attempted exploitation.
- Conduct regular security assessments and code reviews focusing on GraphQL query handling and input validation to prevent similar injection flaws.
- Employ runtime application self-protection (RASP) or Web Application Firewalls (WAF) with custom rules to detect and block SQL injection attempts targeting the GraphQL API.
- Educate administrators and developers on secure API usage and the risks of SQL injection in GraphQL contexts.
- Maintain an incident response plan to quickly address any detected exploitation attempts or data integrity issues.
Description
CVE-2026-25076 is a high-severity SQL injection vulnerability affecting Anchore Enterprise versions prior to 5.25.1. The flaw exists in the GraphQL Reports API and requires an attacker to have authenticated access to this API. Exploitation allows the attacker to execute arbitrary SQL commands, potentially modifying the Anchore Enterprise database contents. No user interaction is needed beyond authentication, and the vulnerability does not require network-level unauthenticated access. Although no known exploits are currently reported in the wild, the vulnerability poses a significant risk to data integrity within affected environments. Organizations using Anchore Enterprise for container security and compliance should prioritize patching to version 5.25.1 or later.