Skip to main content
VulnerabilityPublished Updated

CVE-2026-25112: Genetec RabbitMQ · Incorrect Permissions

Affects Genetec RabbitMQSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.8 High : upgrade to 3.13.7.19 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.13.7.19, 3.4.1.0, 2.11 +5
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Genetec Inc.Genetec RabbitMQAffected
  • <3.13.7.19
Fixed in
  • 3.13.7.19
Genetec Inc.Genetec Mission ControlAffected
  • <3.4.1.0
Fixed in
  • 3.4.1.0
Genetec Inc.Genetec SipeliaAffected
  • <2.11
Fixed in
  • 2.11
Genetec Inc.Genetec Industrial IoTAffected
  • <6.0.196.0
Fixed in
  • 6.0.196.0
Genetec Inc.Genetec Industrial IoTAffected
  • <5.5.118.0
Fixed in
  • 5.5.118.0
Genetec Inc.Genetec Airport Operational ManagerAffected
  • <1.6
Fixed in
  • 1.6

AI-suggested

If you cannot patch yet, restrict local access to trusted users only and review permissions on security-critical resources to limit exposure.

Description

CVE-2026-25112 is a high-severity vulnerability in Genetec RabbitMQ versions prior to 3.13.7.19. It involves improper specification of permissions for a security-critical resource, allowing unintended actors to read or modify it. This can lead to privilege escalation without requiring user interaction. The vulnerability impacts confidentiality, integrity, and availability of the affected system.

References

Community reviews

Loading reviews…