Skip to main content
VulnerabilityPublished

CVE-2026-25525: OpenMage magento-lts · Path Traversal

Affects OpenMage magento-ltsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.9 Medium : upgrade to 20.17.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 20.17.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade magento-lts and openmage/magento-lts to 20.17.0.

Affected software

ProductAffectedFixed in
OpenMagemagento-ltsAffected
  • <20.17.0
Fixed in
  • 20.17.0
GitHubopenmage/magento-ltspkg:github/openmage/magento-ltsOther threatsAffected
  • <20.17.0
Fixed in
  • 20.17.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade OpenMage magento-lts to version 20.17.0 or later, where this path traversal vulnerability is patched. Since this is a community-driven project, verify the upgrade from official OpenMage sources. Patch status is confirmed by the version update; no other mitigation is indicated.

Description

OpenMage magento-lts versions prior to 20.17.0 contain a path traversal vulnerability in the Dataflow module due to an insufficient blacklist filter that can be bypassed by crafted input patterns. An authenticated administrator can exploit this flaw to read arbitrary files on the server. The issue is fixed in version 20.17.0.

References

Community reviews

Loading reviews…