CVE-2026-50076: Apache Fory · Deserialization of Untrusted Data
Affects Apache ForySource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.1.0 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.1.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Apache Fory and org.apache.fory/fory-core and Apache Software Foundation/org.apache.fory:fory-core to 1.1.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Fory | Affected
| Fixed in
|
Mavenorg.apache.fory/fory-corepkg:maven/org.apache.fory/fory-coreOther threats | Affected
| Fixed in
|
MavenApache Software Foundation/org.apache.fory:fory-corepkg:maven/Apache Software Foundation/org.apache.fory:fory-coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Fory fory-core Java SDK to version 1.1.0 or later, where this vulnerability is fixed. No other official remediation or temporary fixes are documented. Patch status is not explicitly confirmed in the vendor advisory, but the recommendation to upgrade indicates an official fix is available in 1.1.0.
Description
A critical deserialization vulnerability (CWE-502) exists in Apache Fory fory-core Java SDK versions before 1.1.0. It allows remote attackers to bypass security checks and invoke dangerous Java serialization hooks via crafted serialized data. Upgrading to version 1.1.0 or later addresses this issue.