Skip to main content
CVE-2026-25547VulnerabilityPublished

CVE-2026-25547: isaacs brace-expansion · ReDoS

Affects isaacs brace-expansionSource CVE Database V5

0

Not known to be exploited · CVSS 9.2 Critical : upgrade to 5.0.1 as a priority.

Data as of 26 Oct 2026, 07:57 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.0.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade brace-expansion and @isaacs/brace-expansion to 5.0.1.

Affected software

ProductAffectedFixed in
isaacsbrace-expansionAffected
  • <5.0.1
Fixed in
  • 5.0.1
npm@isaacs/brace-expansionpkg:npm/@isaacs/brace-expansionOther threatsAffected
  • <5.0.1
Fixed in
  • 5.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately audit their software dependencies to identify usage of @isaacs/brace-expansion versions prior to 5.0.1, including indirect dependencies pulled in by other packages. Upgrading all instances of the library to version 5.0.1 or later is the primary mitigation step. Organizations should implement dependency management tools that enforce version policies and monitor for vulnerable packages. Additionally, input validation and sanitization should be applied to any user-supplied patterns processed by the library to limit the complexity and size of brace expansions. Rate limiting and resource usage monitoring can help detect and mitigate denial of service attempts. For critical production environments, consider isolating services that process untrusted input or running them with resource constraints to prevent system-wide impact. Regularly update Node.js and related dependencies to incorporate security patches. Finally, incorporate this vulnerability into incident response and threat modeling exercises to prepare for potential exploitation scenarios.

Description

CVE-2026-25547 is a critical denial of service vulnerability in versions of the @isaacs/brace-expansion library prior to 5.0.1. The issue arises from inefficient handling of numeric brace ranges, where repeated ranges cause exponential growth in expansion attempts, leading to excessive CPU and memory consumption. This can crash Node.js processes using the vulnerable library without requiring authentication or user interaction. The vulnerability has a CVSS 4.0 base score of 9.2, indicating critical severity. It affects applications and services that incorporate this library for pattern expansion, particularly in JavaScript/TypeScript environments.

References

Community reviews

Loading reviews…