CVE-2026-26015: arc53 DocsGPT · Command Injection
Affects arc53 DocsGPTSource CVE Database V5
Not known to be exploited · CVSS 10.0 Critical : upgrade to 0.16.0 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 1.1% chance of exploitation in 30 days – higher than 67% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.16.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade DocsGPT and arc53/DocsGPT to 0.16.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| arc53DocsGPT | Affected
| Fixed in
|
GitHubarc53/DocsGPTpkg:github/arc53/DocsGPTOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected DocsGPT installations to version 0.16.0 or later, where this vulnerability has been patched. Since this is not a cloud service, users must apply the update themselves. Patch status is confirmed by the vendor's versioning information. No additional mitigations are specified.
Description
DocsGPT is a GPT-powered chat for documentation. From version 0.15.0 to before version 0.16.0, an attacker accessing both the official DocsGPT website or any local and public deployment, can craft a malicious payload bypassing the "MCP test" behavior to achieve arbitrary remote code execution (RCE). This issue has been patched in version 0.16.0.
References
- github.com/arc53/DocsGPT/security/advisories/GHSA-gcrq-f296-2j74 (opens in a new tab)
- github.com/arc53/DocsGPT/releases/tag/0.16.0 (opens in a new tab)
- ox.security/blog/mcp-supply-chain-advisory-rce-vulnerabilities-across-the-ai-ecosystem/ (opens in a new tab)
- ox.security/blog/the-mother-of-all-ai-supply-chains-critical-systemic-vulnerability-at-the-core-of-the-mcp/ (opens in a new tab)