Skip to main content
VulnerabilityPublished Updated

CVE-2026-26143: Microsoft PowerShell 7.4 · Improper Input Validation

Affects Microsoft PowerShell 7.4Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.8 High : upgrade to 7.4.14 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.4.14, 7.5.5
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade PowerShell to 7.4.14 (7.4) or 7.5.5 (7.5).

Affected software

ProductAffectedFixed in
MicrosoftPowerShell 7.4Affected
  • >=7.4.0 <7.4.14
Fixed in
  • 7.4.14
MicrosoftPowerShell 7.5Affected
  • >=7.5.0 <7.5.5
Fixed in
  • 7.5.5

AI-suggested

An official fix is available from Microsoft. Users should apply the security update provided in the Microsoft advisory at https://msrc.microsoft.com/update-guide/vulnerability/CVE-2026-26143 to remediate this vulnerability.

Description

Improper input validation in Microsoft PowerShell allows an unauthorized attacker to bypass a security feature locally.

References

Community reviews

Loading reviews…