Skip to main content
VulnerabilityPublished

CVE-2026-26354: Dell PowerProtect Data Domain · Stack-based Buffer Overflow

Affects Dell PowerProtect Data DomainSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High · fixed in 8.6.1.10 : patch Dell PowerProtect Data Domain soon.

Data as of 29 Oct 2026, 18:38 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.6.1.10, 8.3.1.20 or later, 7.13.1.60 or later +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Dell PowerProtect Data Domain to 8.6.1.10, 8.3.1.20 or later, 7.13.1.60 or later or 2.7.9 with DD OS 8.3.1.30.

Affected software

ProductAffectedFixed in
DellPowerProtect Data DomainAffected
  • =0
Fixed in
  • 8.6.1.10
  • 8.3.1.20 or later
  • 7.13.1.60 or later
  • 2.7.9 with DD OS 8.3.1.30

AI-suggested

If you cannot patch yet, limit remote access to affected systems and monitor for unusual activity. Follow Dell's official communications for updates on patches or mitigations.

Description

Dell PowerProtect Data Domain running Domain Operating System versions 7.7.1.0 through 8.6, and certain LTS2024 and LTS2025 releases, contains a stack-based buffer overflow vulnerability. This flaw allows an unauthenticated remote attacker to potentially execute arbitrary commands on the affected system. The vulnerability is identified as CVE-2026-26354 with a high severity rating and a CVSS score of 8.1. There are no known exploits in the wild at this time.

References

Community reviews

Loading reviews…