Skip to main content
VulnerabilityPublished

CVE-2026-33471: nimiq-block · Improper Input Validation

Affects nimiq-blockSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.6 Critical : upgrade to 1.3.0 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.6Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.3.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade nimiq-block and github/nimiq/nimiq-block to 1.3.0.

Affected software

ProductAffectedFixed in
nimiqnimiq-blockAffected
  • <1.3.0
Fixed in
  • 1.3.0
crates.iogithub/nimiq/nimiq-blockpkg:cargo/github/nimiq/nimiq-blockOther threatsAffected
  • <1.3.0
Fixed in
  • 1.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to nimiq-block version 1.3.0 or later, which includes the official fix for this vulnerability. No other workarounds or mitigations are available. Users should apply this patch promptly to prevent exploitation.

Description

CVE-2026-33471 is a critical vulnerability in the nimiq-block Rust implementation prior to version 1.3.0. It involves improper input validation in the SkipBlockProof::verify function, where out-of-range signer indices can be exploited to bypass quorum checks. This allows a malicious validator with fewer than the required number of signer slots to pass verification by manipulating signature aggregation. The vulnerability has a CVSS score of 9.6, indicating high impact on integrity and availability. A patch fixing this issue was included in version 1.3.0.

References

Community reviews

Loading reviews…