Skip to main content
CVE-2026-27210VulnerabilityPublished Updated

CVE-2026-27210: mpetroff pannellum · Cross-site Scripting

Affects mpetroff pannellumSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium : upgrade to 2.5.7 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.5.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade mpetroff pannellum to 2.5.7.

Affected software

ProductAffectedFixed in
mpetroffpannellumAffected
  • >=2.5.0 <2.5.7
Fixed in
  • 2.5.7

AI-suggested

1. Upgrade Pannellum to version 2.5.7 or later immediately, as this version contains the official fix for the vulnerability. 2. If upgrading is not immediately possible, implement a strict Content-Security-Policy (CSP) header with 'script-src-attr 'none'' to block execution of inline event handlers, effectively mitigating the XSS attack vector. 3. Avoid hosting the pannellum.htm standalone viewer on domains that share cookies with user authentication systems to prevent session hijacking risks. 4. Validate and sanitize all JSON configuration files before use, especially if they originate from untrusted sources, to prevent injection of malicious attributes. 5. Restrict access to configuration files and URLs that load the viewer to trusted users or networks where feasible. 6. Monitor web server logs for unusual requests to the panorama viewer URLs that could indicate exploitation attempts. 7. Educate developers and administrators about the risks of allowing arbitrary HTML attributes in configuration properties and encourage secure coding practices for web content generation.

Description

Pannellum is a lightweight, free, and open source panorama viewer for the web. In versions 3.5.0 through 2.5.6, the hot spot attributes configuration property allowed any attribute to be set, including HTML event handler attributes, allowing for potential XSS attacks. This affects websites hosting the standalone viewer HTML file and any other use of untrusted JSON config files (bypassing the protections of the escapeHTML parameter). As certain events fire without any additional user interaction, visiting a standalone viewer URL that points to a malicious config file — without additional user interaction — is sufficient to trigger the vulnerability and execute arbitrary JavaScript code, which can, for example, replace the contents of the page with arbitrary content and make it appear to be hosted by the website hosting the standalone viewer HTML file. This issue has been fixed in version 2.5.7. To workaround, setting the Content-Security-Policy header to script-src-attr 'none' will block execution of inline event handlers, mitigating this vulnerability. Don't host pannellum.htm on a domain that shares cookies with user authentication to mitigate XSS risk.

References

Community reviews

Loading reviews…