CVE-2026-27314: Apache Cassandra · Privilege Defined With Unsafe Actions
Affects Apache CassandraSource CVE Database V5
Not known to be exploited · CVSS 8.8 High · fixed in 5.0.7 : patch Apache Cassandra soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.0.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Cassandra | Affected
| Fixed in– |
MavenApache Software Foundation/org.apache.cassandra:cassandra-allpkg:maven/Apache Software Foundation/org.apache.cassandra:cassandra-allOther threats | Affected
| Fixed in– |
Mavenorg.apache.cassandra/cassandra-allpkg:maven/org.apache.cassandra/cassandra-allOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Cassandra to version 5.0.7 or later, where this vulnerability is fixed. No other mitigation guidance is provided. Patch status is confirmed by the vendor recommendation to upgrade.
Description
Privilege escalation in Apache Cassandra 5.0 on an mTLS environment using MutualTlsAuthenticator allows a user with only CREATE permission to associate their own certificate identity with an arbitrary role, including a superuser role, and authenticate as that role via ADD IDENTITY. Users are recommended to upgrade to version 5.0.7+, which fixes this issue.