CVE-2026-27384: W3 Total Cache (WordPress plugin) · Improper Validation of Specified Quantity in Input
Affects W3 Total Cache (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 9.0 Critical : upgrade to 2.9.2 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.9.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade W3 Total Cache (WordPress plugin) to 2.9.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| BoldGridW3 Total Cache | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict access to the affected plugin and monitor for unusual activity related to W3 Total Cache. Avoid exposing the affected functionality to untrusted networks or users.
Description
Improper Validation of Specified Quantity in Input vulnerability in BoldGrid W3 Total Cache w3-total-cache allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects W3 Total Cache: from n/a through <= 2.9.1.