Skip to main content
VulnerabilityPublished Updated

CVE-2026-4035: mlflow/mlflow · Insertion of Sensitive Information Into Sent Data

Affects mlflow/mlflowSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 3.11.0 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.0 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.11.0
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade mlflow to 3.11.0.

Affected software

ProductAffectedFixed in
mlflowmlflow/mlflowAffected
  • ≥ unspecified, < 3.11.0
Fixed in–
PyPImlflowpkg:pypi/mlflowOther threatsAffected
  • <3.11.0
Fixed in
  • 3.11.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in mlflow version 3.11.0. Users should upgrade to this version to remediate the vulnerability. Additionally, restrict network access to the MLflow server to trusted clients only and ensure that authentication mechanisms such as basic-auth are properly configured and enabled to prevent unauthenticated or low-privileged access. Consult MLflow documentation for configuration details. A restart or reload of the MLflow service may be required after applying changes.

Description

A vulnerability in mlflow/mlflow versions prior to 3.11.0 allows for the resolution of environment variables in AI Gateway secrets, which can be exploited to exfiltrate sensitive server-side environment credentials to an attacker-controlled endpoint. This issue arises because the `api_key` field in gateway secrets can accept `$ENV_VAR` references, which are resolved against the MLflow server's environment during runtime. The resolved secrets are then sent in provider authentication headers to the configured upstream `api_base`. This vulnerability can be exploited by low-privileged authenticated users in basic-auth deployments or by unauthenticated users in default deployments without `basic-auth`. The impact includes potential leakage of sensitive credentials such as cloud artifact credentials (`AWS_ACCESS_KEY_ID`, `AWS_SECRET_ACCESS_KEY`), which could lead to artifact poisoning and cross-boundary code execution in downstream environments. The issue is fixed in version 3.11.0.

References

Community reviews

Loading reviews…