CVE-2026-27449: Umbraco.Engage.Forms · Improper Access Control
Affects Umbraco.Engage.FormsSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 17.1.1 or 16.2.1 soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.1.1, 16.2.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Umbraco.Engage.Forms to 17.1.1 or 16.2.1; umbraco/Umbraco.Engage.Forms to 16.2.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| umbracoUmbraco.Engage.Forms | Affected
| Fixed in
|
| umbracoUmbraco.Engage.Forms | Affected
| Fixed in
|
GitHubumbraco/Umbraco.Engage.Formspkg:github/umbraco/Umbraco.Engage.FormsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Immediately upgrade Umbraco Engage to version 16.2.1 or 17.1.1 or later to apply the official patches that enforce proper authentication and authorization on the affected API endpoints.
- Conduct a thorough audit of API endpoint configurations to ensure no other endpoints are exposed without proper access controls.
- Implement network-level protections such as IP whitelisting or VPN access to restrict access to the Engage platform's management interfaces and APIs.
- Monitor API access logs for unusual patterns indicative of enumeration attacks, such as sequential or high-volume requests to identifier parameters.
- Employ Web Application Firewalls (WAFs) with custom rules to detect and block suspicious API requests targeting the vulnerable endpoints.
- Review and enhance overall access control policies and authentication mechanisms within the Engage deployment to prevent similar issues.
- Educate development and operations teams about secure API design principles, emphasizing the importance of enforcing authentication and authorization on all endpoints.
- Plan for regular vulnerability assessments and penetration tests focusing on API security to identify and remediate access control weaknesses proactively.
Description
Umbraco Engage is a business intelligence platform. A vulnerability has been identified in Umbraco Engage prior to versions 16.2.1 and 17.1.1 where certain API endpoints are exposed without enforcing authentication or authorization checks. The affected endpoints can be accessed directly over the network without requiring a valid session or user credentials. By supplying a user-controlled identifier parameter (e.g., ?id=), an attacker can retrieve sensitive data associated with arbitrary records. Because no access control validation is performed, the endpoints are vulnerable to enumeration attacks, allowing attackers to iterate over identifiers and extract data at scale. An unauthenticated attacker can retrieve sensitive Engage-related data by directly querying the affected API endpoints. The vulnerability allows arbitrary record access through predictable or enumerable identifiers. The confidentiality impact is considered high. No direct integrity or availability impact has been identified. The scope of exposed data depends on the deployment but may include analytics data, tracking data, customer-related information, or other Engage-managed content. The vulnerability affects both v16 and v17. Patches have already been released. Users are advised to update to 16.2.1 or 17.1.1. No known workarounds are available.