Skip to main content
VulnerabilityPublished

CVE-2026-27465: fleetdm fleet · Insertion of Sensitive Information Into Sent Data

Affects fleetdm fleetSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 1.3 Low : upgrade to 4.80.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
1.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.80.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade fleet and fleetdm/fleet to 4.80.1.

Affected software

ProductAffectedFixed in
fleetdmfleetAffected
  • <4.80.1
Fixed in
  • 4.80.1
GitHubfleetdm/fleetpkg:github/fleetdm/fleetOther threatsAffected
  • <4.80.1
Fixed in
  • 4.80.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Administrators should upgrade Fleet to version 4.80.1 or later, which patches the vulnerability by properly restricting access to sensitive Google service account credentials. If immediate upgrading is not feasible, the Google Calendar integration should be disabled or removed from Fleet to prevent exposure. Additionally, affected Google service account credentials must be rotated immediately to invalidate any potentially compromised keys. Organizations should audit user roles and permissions within Fleet to ensure that only necessary users have access, minimizing the risk of credential exposure. Monitoring and logging access to the configuration API endpoint can help detect any unauthorized attempts to retrieve sensitive data. Finally, organizations should review their Google Workspace audit logs for unusual access patterns linked to the service account to identify potential misuse.

Description

Fleet is open source device management software. In versions prior to 4.80.1, a vulnerability in Fleet’s configuration API could expose Google Calendar service account credentials to authenticated users with low-privilege roles. This may allow unauthorized access to Google Calendar resources associated with the service account. Fleet returns configuration data through an API endpoint that is accessible to authenticated users, including those with the lowest-privilege “Observer” role. In affected versions, Google Calendar service account credentials were not properly obfuscated before being returned. As a result, a low-privilege user could retrieve the service account’s private key material. Depending on how the Google Calendar integration is configured, this could allow unauthorized access to calendar data or other Google Workspace resources associated with the service account. This issue does not allow escalation of privileges within Fleet or access to device management functionality. Version 4.80.1 patches the issue. If an immediate upgrade is not possible, administrators should remove the Google Calendar integration from Fleet and rotate the affected Google service account credentials.

References

Community reviews

Loading reviews…