Skip to main content
VulnerabilityPublished Updated

CVE-2026-27612: denpiligrim repostat · Cross-site Scripting

Affects denpiligrim repostatSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.0.1 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade repostat and denpiligrim/repostat to 1.0.1.

Affected software

ProductAffectedFixed in
denpiligrimrepostatAffected
  • <1.0.1
Fixed in
  • 1.0.1
npmdenpiligrim/repostatpkg:npm/denpiligrim/repostatOther threatsAffected
  • <1.0.1
Fixed in
  • 1.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate this vulnerability, organizations should upgrade to denpiligrim repostat version 1.0.1 or later, where the unsafe use of dangerouslySetInnerHTML has been removed. Developers should avoid passing untrusted or unsanitized user input directly into the repo prop or any other props that are rendered as HTML. Input validation and sanitization should be enforced on all user-supplied data before rendering. If upgrading is not immediately possible, developers should patch the component to remove dangerouslySetInnerHTML usage and replace it with safe JSX rendering that escapes HTML entities. Additionally, implementing Content Security Policy (CSP) headers can help mitigate the impact of XSS by restricting script execution. Web application firewalls (WAFs) can also be configured to detect and block reflected XSS attack patterns. Regular security code reviews and dependency audits should be conducted to identify and remediate similar issues proactively.

Description

Repostat is a React component to fetch and display GitHub repository info. Prior to version 1.0.1, the `RepoCard` component is vulnerable to Reflected Cross-Site Scripting (XSS). The vulnerability occurs because the component uses React's `dangerouslySetInnerHTML` to render the repository name (`repo` prop) during the loading state without any sanitization. If a developer using this package passes unvalidated user input directly into the `repo` prop (for example, reading it from a URL query parameter), an attacker can execute arbitrary JavaScript in the context of the user's browser. In version 1.0.1, the use of dangerouslySetInnerHTML has been removed, and the repo prop is now safely rendered using standard React JSX data binding, which automatically escapes HTML entities.

References

Community reviews

Loading reviews…