Skip to main content
VulnerabilityPublished Updated

CVE-2026-27654: F5 NGINX Open Source · Heap-based Buffer Overflow

Affects F5 NGINX Open SourceSource CVE Database V5

0
Compare

Not known to be exploited · 25% EPSS · CVSS 8.2 High : upgrade to 1.29.7 or 1.28.3 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
25.9% chance of exploitation in 30 days – higher than 97% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.29.7, 1.28.3, 1.29.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade NGINX Open Source to 1.29.7 or 1.28.3; the Red Hat redhat/nginx package to 1.29.0.

Affected software

ProductAffectedFixed in
F5NGINX Open SourceAffected
  • >=1.29.0 <1.29.7
Fixed in
  • 1.29.7
F5NGINX Open SourceAffected
  • >=0.5.13 <1.28.3
Fixed in
  • 1.28.3
F5NGINX PlusAffected
  • >=R34
  • >=R33
  • =R36
  • =R35
  • =R32
Fixed in–
Red Hatredhat/nginxpkg:rpm/redhat/nginxOther threatsAffected
  • <1.29.0
Fixed in
  • 1.29.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available to remediate this vulnerability. Users should apply the official fixes provided by F5 and Red Hat as soon as possible. No alternative mitigations meeting vendor criteria are currently available. Review and update NGINX configurations to avoid using vulnerable combinations of DAV MOVE or COPY methods with prefix location and alias directives until patched.

Description

CVE-2026-27654 is a heap-based buffer overflow vulnerability in the ngx_http_dav_module of NGINX Open Source and NGINX Plus. It occurs when the configuration uses DAV module MOVE or COPY methods combined with prefix location and alias directives. Exploitation can cause termination of the NGINX worker process (denial of service) or modification of file names outside the document root. The impact on system integrity is limited due to the low privileges of the NGINX worker process user. A patch is available to address this vulnerability.

References

Community reviews

Loading reviews…