Skip to main content
VulnerabilityPublished

CVE-2026-27704: dart-lang sdk · Path Traversal

Affects dart-lang sdkSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.6 Medium : upgrade to 3.11.0 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
6.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.11.0, 3.41.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade sdk and dart/sdk to 3.11.0; flutter to 3.41.0.

Affected software

ProductAffectedFixed in
dart-langsdkAffected
  • <3.11.0
Fixed in
  • 3.11.0
dart-langflutterAffected
  • <3.41.0
Fixed in
  • 3.41.0
Pubdart/sdkpkg:pub/dart/sdkOther threatsAffected
  • <3.11.0
Fixed in
  • 3.11.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Upgrade to Dart SDK version 3.11.0 or later and Flutter SDK version 3.41.0 or later to apply the official patch that normalizes file paths during extraction.
  2. Restrict package sources to trusted repositories such as pub.dev, which vets packages to exclude symlinks, or trusted git dependencies.
  3. Implement strict controls and scanning on third-party or private package archives before use, including verifying absence of symlinks or path traversal payloads.
  4. Use sandboxed or isolated environments for package extraction to limit potential damage from malicious archives.
  5. Monitor file system changes in the PUB_CACHE directory and related paths for unusual activity indicative of exploitation attempts.
  6. Educate developers and CI/CD operators about the risks of using untrusted packages and encourage best practices in dependency management.
  7. Consider integrating automated security scanning tools that detect path traversal or symlink abuse in package archives prior to installation.

Description

The Dart and Flutter SDKs provide software development kits for the Dart programming language. In versions of the Dart SDK prior to 3.11.0 and the Flutter SDK prior to version 3.41.0, when the pub client (`dart pub` and `flutter pub`) extracts a package in the pub cache, a malicious package archive can have files extracted outside the destination directory in the `PUB_CACHE`. A fix has been landed in commit 26c6985c742593d081f8b58450f463a584a4203a. By normalizing the file path before writing file, the attacker can no longer traverse up via a symlink. This patch is released in Dart 3.11.0 and Flutter 3.41.0.vAll packages on pub.dev have been vetted for this vulnerability. New packages are no longer allowed to contain symlinks. The pub client itself doesn't upload symlinks, but duplicates the linked entry, and has been doing this for years. Those whose dependencies are all from pub.dev, third-party repositories trusted to not contain malicious code, or git dependencies are not affected by this vulnerability.

References

Community reviews

Loading reviews…